aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 9 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index a6aa1de..8d50385 100644
--- a/meson.build
+++ b/meson.build
@@ -151,10 +151,12 @@ ida_srcs = [ 'ida.c', 'man.c', 'hex.c', 'x11.c', 'viewer.c',
ida_deps = [ pixman_dep, exif_dep, image_deps, math_dep,
motif_dep, xpm_dep, xt_dep, xext_dep, x11_dep ]
-executable('ida',
- sources : ida_srcs,
- dependencies : ida_deps,
- include_directories : trans_inc,
- install : true)
-install_man('man/ida.1')
-install_data('Ida.ad', install_dir : x11resdir)
+if motif_dep.found()
+ executable('ida',
+ sources : ida_srcs,
+ dependencies : ida_deps,
+ include_directories : trans_inc,
+ install : true)
+ install_man('man/ida.1')
+ install_data('Ida.ad', install_dir : x11resdir)
+endif