aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2017-08-30 12:47:00 +0200
committerGerd Hoffmann <kraxel@redhat.com>2017-08-30 12:47:00 +0200
commit2f41f6e7005082406f889d84fbb9b308d5e521a0 (patch)
tree80bcfe01e77c4418be4bc1ab5717cfa303c22a04 /meson.build
parent35b649a7f2025330c691c1724743d22cf19c425e (diff)
downloadfbida-2f41f6e7005082406f889d84fbb9b308d5e521a0.tar.gz
meson. fix app defaults install
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 8d50385..35045ad 100644
--- a/meson.build
+++ b/meson.build
@@ -132,7 +132,8 @@ executable('kbdtest', [ 'kbdtest.c', 'kbd.c' ])
# build ida
mkfallback = find_program('scripts/fallback.pl')
hexify = find_program('scripts/hexify.sh')
-ida_ad = custom_target('ida-app-defaults',
+copy = find_program('cp')
+ida_ad = custom_target('ida-app-defaults-fallback',
input : ['Ida.ad'],
output : ['Ida.ad.h'],
command : [ mkfallback, '@INPUT@', '@OUTPUT@'])
@@ -158,5 +159,9 @@ if motif_dep.found()
include_directories : trans_inc,
install : true)
install_man('man/ida.1')
- install_data('Ida.ad', install_dir : x11resdir)
+ custom_target('ida-app-defaults',
+ input : ['Ida.ad'],
+ output : ['Ida'],
+ command : [ copy, '@INPUT@', '@OUTPUT@'],
+ install : true, install_dir : x11resdir)
endif