aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2019-03-01 10:15:17 +0100
committerGerd Hoffmann <kraxel@redhat.com>2019-03-01 10:15:17 +0100
commit40f389d427d46159d6ddd249f73fad59b507780e (patch)
treed365099594291bf19128216b485a8171eca2afe5 /meson.build
parenteb769e3d7f4a073d4c37ed524ebd5017c6a578f5 (diff)
downloadfbida-40f389d427d46159d6ddd249f73fad59b507780e.tar.gz
fbcon: add config file
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index af71b23..aa695f2 100644
--- a/meson.build
+++ b/meson.build
@@ -27,6 +27,7 @@ webp_dep = dependency('libwebp', required : false)
udev_dep = dependency('libudev')
input_dep = dependency('libinput')
xkb_dep = dependency('xkbcommon')
+glib_dep = dependency('glib-2.0')
tsm_dep = dependency('libtsm', required : false)
# other library deps
@@ -129,7 +130,7 @@ executable('fbpdf',
# build fbcon
fbcon_srcs = [ 'fbcon.c', 'drmtools.c', 'fbtools.c', 'gfx.c', 'vt.c', 'kbd.c' ]
-fbcon_deps = [ drm_dep, cairo_dep, util_dep, udev_dep, input_dep, xkb_dep, tsm_dep ]
+fbcon_deps = [ drm_dep, cairo_dep, util_dep, udev_dep, input_dep, xkb_dep, glib_dep, tsm_dep ]
if tsm_dep.found()
executable('fbcon',