aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2019-04-15 18:20:50 +0200
committerGerd Hoffmann <kraxel@redhat.com>2019-04-15 18:20:50 +0200
commit5737cf1d24c868a55eafc59a51c000dc7f4f63f6 (patch)
treeef9c8e8fa95723b586fa882b1222e0daac91ad3d /meson.build
parent168c57b57f2fb4440943d4e672dee4ca34f060b8 (diff)
downloadfbida-5737cf1d24c868a55eafc59a51c000dc7f4f63f6.tar.gz
use xkbcommon
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 49d29d8..6516aae 100644
--- a/meson.build
+++ b/meson.build
@@ -80,6 +80,9 @@ trans_inc = include_directories(''.join(['jpeg/', jpeg_ver]))
if motif_dep.found()
config.set('HAVE_MOTIF', true)
endif
+if target_machine.system() == 'linux'
+ config.set('SYSTEM_LINUX', true)
+endif
configure_file(output : 'config.h', configuration : config)
add_global_arguments(['-include', 'config.h'], language : 'c')