aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog16
-rw-r--r--debian/control20
-rw-r--r--debian/copyright21
-rw-r--r--debian/libpcd-dev.files3
-rw-r--r--debian/libpcd2.files1
-rwxr-xr-xdebian/rules48
6 files changed, 109 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..f109587
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,16 @@
+libpcd (1.0.1) unstable; urgency=low
+
+ * fix a number of 64bit bugs (s/unsigned long/uint32_t/
+ in several places ...).
+
+ -- Gerd Knorr <kraxel@debian.org> Tue, 22 Jul 2003 11:58:53 +0200
+
+libpcd (1.0) unstable; urgency=low
+
+ * initial release (closes: #132780).
+
+ -- Gerd Knorr <kraxel@debian.org> Fri, 8 Feb 2002 14:23:46 +0100
+
+Local variables:
+mode: debian-changelog
+End:
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..264e263
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,20 @@
+Source: libpcd
+Section: devel
+Priority: optional
+Build-depends: debhelper (>=3.0)
+Maintainer: Gerd Knorr <kraxel@debian.org>
+Standards-Version: 3.6.0
+
+Package: libpcd2
+Architecture: any
+Section: devel
+Depends: ${shlibs:Depends}
+Description: A library for reading PhotoCD images
+ A library for reading PhotoCD images
+
+Package: libpcd-dev
+Architecture: any
+Section: devel
+Depends: libpcd2 (= ${Source-Version})
+Description: Header files and static library for libpcd
+ Header files and static library for libpcd
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..68fc1e8
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,21 @@
+This is libpcd, written and maintained by Gerd Knorr <kraxel@bytesex.org>
+
+The original source can always be found at:
+ ftp://ftp.debian.org/dists/unstable/main/source/
+
+Copyright (C) 1996-2002 Gerd Knorr
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License with
+ the Debian GNU/Linux distribution in file /usr/share/common-licenses/GPL;
+ if not, write to the Free Software Foundation, Inc., 59 Temple Place,
+ Suite 330, Boston, MA 02111-1307 USA
diff --git a/debian/libpcd-dev.files b/debian/libpcd-dev.files
new file mode 100644
index 0000000..40d9aba
--- /dev/null
+++ b/debian/libpcd-dev.files
@@ -0,0 +1,3 @@
+/usr/lib/libpcd.a
+/usr/lib/libpcd.so
+/usr/include/pcd.h
diff --git a/debian/libpcd2.files b/debian/libpcd2.files
new file mode 100644
index 0000000..352d677
--- /dev/null
+++ b/debian/libpcd2.files
@@ -0,0 +1 @@
+/usr/lib/libpcd.so.*
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..77ced88
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,48 @@
+#!/usr/bin/make -f
+
+HERE := $(shell pwd)
+DEST := $(HERE)/debian/tmp
+
+# debhelper
+export DH_COMPAT=3
+
+build:
+ $(MAKE) prefix=/usr $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ rm -rf $(DEST)
+ make DESTDIR=$(DEST) prefix=/usr install
+
+ dh_movefiles
+
+binary-indep: build install
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs -p libpcd2 README
+ dh_installdocs -p libpcd-dev README pcd.html pcd.css
+ dh_installchangelogs
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_makeshlibs -V
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install
+