aboutsummaryrefslogtreecommitdiffstats
path: root/vgasrc/geodevga.h
Commit message (Collapse)AuthorAgeFilesLines
* Fix typos found by codespellStefan Weil2015-10-091-1/+1
| | | | | Signed-off-by: Stefan Weil <sw@weilnetz.de> Signed-off-by: Kevin O'Connor <kevin@koconnor.net>
* Minor - replace some tab characters that slipped into the code.Kevin O'Connor2014-04-111-1/+1
| | | | Signed-off-by: Kevin O'Connor <kevin@koconnor.net>
* geodevga: fix wrong define nameChristian Gmeiner2013-02-151-1/+1
| | | | Signed-off-by: Christian Gmeiner <christian.gmeiner@gmail.com>
* Normalize POST initialization function name suffixes.Kevin O'Connor2013-02-051-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | The POST phase has to invoke many initialization functions, and these functions can have complex inter-dependencies. Try to categorize the functions into 4 classes: preinit - functions called very early in POST where function ordering is very important and the code has limited access to other interfaces. init - functions that initialize internal interfaces and standard external interfaces. This code is generally not dependent on particular hardware and typically does not communicate directly with any hardware devices. setup - functions which access hardware or are dependent on particular hardware or platform devices. prepboot - functions that finalize internal interfaces and that prepare for the boot phase. This patch attempts to normalize the suffixes - functions that used _init(), _setup(), _finalize(), or similar that did not follow the above pattern were renamed. Other than function name changes, there should be no code impact to this patch. Signed-off-by: Kevin O'Connor <kevin@koconnor.net>
* geodevga: Add defines for VP_MSR_PADSELChristian Gmeiner2012-10-071-0/+4
| | | | Signed-off-by: Christian Gmeiner <christian.gmeiner@gmail.com>
* geodevga: Add VP_MSR_CONFIG definesChristian Gmeiner2012-10-071-0/+7
| | | | | | | This patch adds all needed defines to setup the wanted output mode. Signed-off-by: Christian Gmeiner <christian.gmeiner@gmail.com>
* geodevga: Add some basic flat panel definesChristian Gmeiner2012-10-071-0/+9
| | | | Signed-off-by: Christian Gmeiner <christian.gmeiner@gmail.com>
* geodevga: Rename defines to better match a well defined naming schemaChristian Gmeiner2012-10-071-9/+9
| | | | | | | The following nameing schema is used: PART_REGISTER_BIT_DESCRIPTION Signed-off-by: Christian Gmeiner <christian.gmeiner@gmail.com>
* Add framebuffer size detectionChristian Gmeiner2012-09-031-0/+1
| | | | | | | It is possible to read out the framebuffer size via msr. The size information is needed for VESA later. Signed-off-by: Christian Gmeiner <christian.gmeiner@gmail.com>
* Remove Extened CRTC Register functionsChristian Gmeiner2012-09-031-7/+0
| | | | | | | As the access the DC registers via memory, we dont need to work with the extended CRTC register to setup the DC-VGA-mapping. Signed-off-by: Christian Gmeiner <christian.gmeiner@gmail.com>
* vgabios: Use regular pci_config_readl func in geode code.Kevin O'Connor2012-01-161-6/+0
| | | | Signed-off-by: Kevin O'Connor <kevin@koconnor.net>
* vgabios: Add the geode GX2 functionality.Nils2012-01-141-2/+4
| | | | Signed-off-by: Nils Jacobs <njacobs8 at adsltotaal.nl>
* vgabios: Some little geode cleanup.Nils2012-01-141-8/+6
| | | | Signed-off-by: Nils Jacobs <njacobs8 at adsltotaal.nl>
* vgabios: Make the naming in the LX code generic to Geode.Nils2012-01-141-0/+81
Signed-off-by: Nils Jacobs <njacobs8 at adsltotaal.nl>