aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2019-04-16 12:30:24 +0200
committerGerd Hoffmann <kraxel@redhat.com>2019-04-16 12:30:24 +0200
commit2d62ce153a386d8c67dfd0d965d746a754ef4129 (patch)
treec7ce4c59eceb3b6eb179ae8075597ac49143dde7 /meson.build
parent5737cf1d24c868a55eafc59a51c000dc7f4f63f6 (diff)
downloadfbida-2d62ce153a386d8c67dfd0d965d746a754ef4129.tar.gz
logind tweaks
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 9 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 6516aae..590fed8 100644
--- a/meson.build
+++ b/meson.build
@@ -91,12 +91,13 @@ add_global_arguments(['-include', 'config.h'], language : 'c')
# build fbi
fbi_srcs = [ 'fbi.c', 'fb-gui.c', 'desktop.c',
'parseconfig.c', 'fbiconfig.c',
- 'vt.c', 'kbd.c', 'fbtools.c', 'drmtools.c', 'gfx.c',
+ 'vt.c', 'kbd.c', 'logind.c',
+ 'fbtools.c', 'drmtools.c', 'gfx.c',
'filter.c', 'op.c', 'jpegtools.c',
trans_src, read_srcs ]
fbi_deps = [ drm_dep, pixman_dep, cairo_dep,
exif_dep, image_deps,
- math_dep, udev_dep, input_dep, xkb_dep ]
+ math_dep, udev_dep, input_dep, xkb_dep, systemd_dep ]
executable('fbi',
sources : fbi_srcs,
@@ -125,10 +126,11 @@ executable('thumbnail.cgi',
# build fbpdf
fbpdf_srcs = [ 'fbpdf.c', 'parseconfig.c', 'fbiconfig.c',
- 'vt.c', 'kbd.c', 'fbtools.c', 'drmtools.c', 'gfx.c' ]
+ 'vt.c', 'kbd.c', 'logind.c',
+ 'fbtools.c', 'drmtools.c', 'gfx.c' ]
fbpdf_deps = [ drm_dep, gbm_dep, epoxy_dep,
pixman_dep, poppler_dep, cairo_dep,
- udev_dep, input_dep, xkb_dep ]
+ udev_dep, input_dep, xkb_dep, systemd_dep ]
executable('fbpdf',
sources : fbpdf_srcs,
@@ -136,7 +138,8 @@ executable('fbpdf',
install : true)
# build fbcon
-fbcon_srcs = [ 'fbcon.c', 'drmtools.c', 'fbtools.c', 'gfx.c', 'vt.c', 'kbd.c', 'logind.c' ]
+fbcon_srcs = [ 'fbcon.c', 'drmtools.c', 'fbtools.c', 'gfx.c',
+ 'vt.c', 'kbd.c', 'logind.c' ]
fbcon_deps = [ drm_dep, cairo_dep, util_dep, udev_dep, input_dep, xkb_dep, glib_dep,
tsm_dep, systemd_dep ]
@@ -151,7 +154,7 @@ endif
# build kbdtest
executable('kbdtest',
- sources : [ 'kbdtest.c', 'kbd.c' ],
+ sources : [ 'kbdtest.c', 'kbd.c', 'logind.c' ],
dependencies : [ udev_dep, input_dep, xkb_dep, systemd_dep ] )
# build vttest