aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2019-03-01 15:16:21 +0100
committerGerd Hoffmann <kraxel@redhat.com>2019-03-01 15:16:21 +0100
commit568029f176168fe9c0718b37767bc69587e92eca (patch)
treedcf5788c42d84e07fd5dac751492d30df9003b1d /meson.build
parent40f389d427d46159d6ddd249f73fad59b507780e (diff)
downloadfbida-568029f176168fe9c0718b37767bc69587e92eca.tar.gz
logind support
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 9 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index aa695f2..1505d6d 100644
--- a/meson.build
+++ b/meson.build
@@ -29,6 +29,7 @@ input_dep = dependency('libinput')
xkb_dep = dependency('xkbcommon')
glib_dep = dependency('glib-2.0')
tsm_dep = dependency('libtsm', required : false)
+systemd_dep = dependency('libsystemd', required : false, version : '>=221')
# other library deps
cc = meson.get_compiler('c')
@@ -65,6 +66,9 @@ if webp_dep.found()
read_srcs += 'rd/read-webp.c'
config.set('HAVE_LIBWEBP', true)
endif
+if systemd_dep.found()
+ config.set('HAVE_SYSTEMD', true)
+endif
# jpeg transformation support
jpeg_run = run_command('scripts/jpeg-version.sh')
@@ -89,7 +93,7 @@ fbi_srcs = [ 'fbi.c', 'fb-gui.c', 'desktop.c',
trans_src, read_srcs ]
fbi_deps = [ drm_dep, pixman_dep, cairo_dep,
exif_dep, image_deps,
- math_dep, udev_dep, input_dep ]
+ math_dep, udev_dep, input_dep, systemd_dep ]
executable('fbi',
sources : fbi_srcs,
@@ -121,7 +125,7 @@ fbpdf_srcs = [ 'fbpdf.c', 'parseconfig.c', 'fbiconfig.c',
'vt.c', 'kbd.c', 'fbtools.c', 'drmtools.c', 'gfx.c' ]
fbpdf_deps = [ drm_dep, gbm_dep, epoxy_dep,
pixman_dep, poppler_dep, cairo_dep,
- udev_dep, input_dep ]
+ udev_dep, input_dep, systemd_dep ]
executable('fbpdf',
sources : fbpdf_srcs,
@@ -130,7 +134,8 @@ executable('fbpdf',
# build fbcon
fbcon_srcs = [ 'fbcon.c', 'drmtools.c', 'fbtools.c', 'gfx.c', 'vt.c', 'kbd.c' ]
-fbcon_deps = [ drm_dep, cairo_dep, util_dep, udev_dep, input_dep, xkb_dep, glib_dep, tsm_dep ]
+fbcon_deps = [ drm_dep, cairo_dep, util_dep, udev_dep, input_dep, xkb_dep, glib_dep,
+ tsm_dep, systemd_dep ]
if tsm_dep.found()
executable('fbcon',
@@ -144,7 +149,7 @@ endif
# build kbdtest
executable('kbdtest',
sources : [ 'kbdtest.c', 'kbd.c' ],
- dependencies : [ udev_dep, input_dep ] )
+ dependencies : [ udev_dep, input_dep, systemd_dep ] )
# build ida
mkfallback = find_program('scripts/fallback.pl')